6302 C++ Programming Manual: D:/6302/Cpp Directory Reference

6302 C++ Programming Manual
Cpp Directory Reference

Files

file JY6302.h
@SectionBegin JY6302 FileHead
Generated by doxygen 1.9.1


6302 C++ Programming Manual: D:/6302/Cpp/JY6302.h File Reference

Typedefs | Enumerations | Functions
JY6302.h File Reference

@SectionBegin JY6302 FileHead More...

Typedefs

typedef void * JY6302_DeviceHandle
Windows. More...

Enumerations

enum | JY6302_AI_VoltageRange { JY6302_AI_78125uV = 0 , JY6302_AI_39062uV = 1 , JY6302_AI_19531uV = 2 }
enum | JY6302_AI_SampleMode { JY6302_AI_Finite = 0 , JY6302_AI_Continuous = 1 , JY6302_AI_Single = 2 }
enum | JY6302_AI_TriggerType { JY6302_AI_Immediately = 0 , JY6302_AI_Digital = 1 , JY6302_AI_Soft = 2 }
enum | JY6302_AI_TriggerMode { JY6302_AI_Trigger_Start = 0 , JY6302_AI_Trigger_Reference = 1 , JY6302_AI_Trigger_Advance = 2 }
enum | JY6302_DigitalTriggerEdge { JY6302_Rising = 0 , JY6302_Falling = 1 }
enum JY6302_IOTerminal {
JY6302_PFI_0 = 8 , JY6302_PFI_1 = 9 , JY6302_PFI_2 = 10 , JY6302_PFI_3 = 11 ,
JY6302_TriggerBus_0 = 16 , JY6302_TriggerBus_1 = 17 , JY6302_TriggerBus_2 = 18 , JY6302_TriggerBus_3 = 19 ,
JY6302_TriggerBus_4 = 20 , JY6302_TriggerBus_5 = 21 , JY6302_TriggerBus_6 = 22 , JY6302_TriggerBus_7 = 23 ,
JY6302_STAR = 7
}
enum | JY6302_Signal_Source { JY6302_AI_SampleClock = 1 , JY6302_AI_StartTrig = 25 , JY6302_AI_ReferenceTrig = 27 , JY6302_AI_AdvanceTrig = 29 }
enum JY6302_Singnal_Destination {
JY6302_EXPORT_PFI_0 = 8 , JY6302_EXPORT_PFI_1 = 9 , JY6302_EXPORT_PFI_2 = 10 , JY6302_EXPORT_PFI_3 = 11 ,
JY6302_EXPORT_TriggerBus_0 = 16 , JY6302_EXPORT_TriggerBus_1 = 17 , JY6302_EXPORT_TriggerBus_2 = 18 , JY6302_EXPORT_TriggerBus_3 = 19 ,
JY6302_EXPORT_TriggerBus_4 = 20 , JY6302_EXPORT_TriggerBus_5 = 21 , JY6302_EXPORT_TriggerBus_6 = 22 , JY6302_EXPORT_TriggerBus_7 = 23 ,
JY6302_EXPORT_STAR = 7
}
enum | JY6302_SampleClockSource { JY6302_InternalSampleClock = 0 , JY6302_ExternalSampleClock = 1 }
enum | JY6302_HJ_Data_Source { JY6302_HJ_CONV_DATA = 0 , JY6302_HJ_CONV_TIME = 1 }
enum JY6302_ThermocoupleType {
JY6302_TypeR = 0 , JY6302_TypeS = 1 , JY6302_TypeB = 2 , JY6302_TypeJ = 3 ,
JY6302_TypeT = 4 , JY6302_TypeE = 5 , JY6302_TypeK = 6 , JY6302_TypeN = 7 ,
JY6302_TypeC = 8 , JY6302_TypeA = 9
}

Functions

JY6302API int | JY6302_Open (int slotNumber, JY6302_DeviceHandle *hDevice)
Open the 6302 series boards using the slot number or the board serial number. More...
JY6302API int | JY6302_OpenByName (const char *cardName, JY6302_DeviceHandle *hDevice)
Open this 6302 series boards using the board alias name which is set by JYTEK utility JYDM. More...
JY6302API int | JY6302_GetDeviceID (JY6302_DeviceHandle hDevice, int *deviceID)
Obtain the board ID. More...
JY6302API int | JY6302_GetDeviceSerialNumber (JY6302_DeviceHandle hDevice, char *serialNumber, int length)
Obtain the device serialNumber More...
JY6302API int | JY6302_Close (JY6302_DeviceHandle hDevice)
JY6302API int | JY6302_AI_EnableChannel (JY6302_DeviceHandle hDevice, unsigned int channelsCount, unsigned int *channelsIndex, JY6302_AI_VoltageRange *inputVoltageRange, JY6302_ThermocoupleType *thermocoupleType)
Enable AI channels. More...
JY6302API int | JY6302_AI_SetExternalSampleClockTerminal (JY6302_DeviceHandle hDevice, JY6302_IOTerminal extSampleClkSrc)
JY6302API int | JY6302_AI_SetSampleRate (JY6302_DeviceHandle hDevice, double sampleRate, int REJ60, JY6302_SampleClockSource sampleClkSrc, double *actualSampleRate, int *powerLineRejEnabled)
JY6302API int | JY6302_AI_GetActualSampleRate (double sampleRate, int REJ60, unsigned int *chIndex, unsigned int chCount, double *actualSampleRate, int *powerLineRejEnabled)
JY6302API int | JY6302_AI_SetSamplesToAcquire (JY6302_DeviceHandle hDevice, unsigned int samplesToAcquire)
JY6302API int | JY6302_AI_SetSampleMode (JY6302_DeviceHandle hDevice, JY6302_AI_SampleMode mode)
JY6302API int | JY6302_AI_EnableCJUserData (JY6302_DeviceHandle hDevice, bool enable)
Enable/disable user-defined cold junction temperatures More...
JY6302API int | JY6302_AI_EnableNonTCMode (JY6302_DeviceHandle hDevice, bool enable)
Enables/disables Non-thermocouple voltage signal measurement mode. More...
JY6302API int | JY6302_AI_Start (JY6302_DeviceHandle hDevice)
JY6302API int | JY6302_AI_Stop (JY6302_DeviceHandle hDevice)
JY6302API int | JY6302_AI_ReadMeasuringJuctionRawData (JY6302_DeviceHandle hDevice, int *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
JY6302API int | JY6302_AI_ReadMeasuringJuctionData (JY6302_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeout, unsigned int *actualReadLength)
JY6302API int | JY6302_AI_ReadMeasuringJunctionSinglePoint (JY6302_DeviceHandle hDevice, double *dataBuffer)
JY6302API int | JY6302_AI_ReadReferenceJunctionRawData (JY6302_DeviceHandle hDevice, short *dataBuffer, unsigned int dataLength, int timeout, unsigned int *actualReadLength)
Read Measuring Reference Juction Raw data More...
JY6302API int | JY6302_AI_ReadReferenceJunctionData (JY6302_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeout, unsigned int *actualReadLength)
Read Measuring Reference Juction data(��) More...
JY6302API int | JY6302_AI_ReadReferenceJunctionSinglePoint (JY6302_DeviceHandle hDevice, double *dataBuffer)
JY6302API int | JY6302_AI_ReadData (JY6302_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeout, unsigned int *actualReadLength)
The acquisition data of the measuring and the reference are read at the same time, and the cold is compensated and converted to temperature���棩 More...
JY6302API int | JY6302_AI_ReadSinglePoint (JY6302_DeviceHandle hDevice, double *dataBuffer, int channelID)
The unbuffered single point reads the acquisition data of both the measuring and reference, and the cold junction compensates for it and converts it to temperature More...
JY6302API int | JY6302_AI_WaitUntilDone (JY6302_DeviceHandle hDevice, int timeout, bool *done)
JY6302API int | JY6302_AI_CheckBufferStatus (JY6302_DeviceHandle hDevice, unsigned long long *availableSamplesCount, bool *overflow)
Check AI device buffer status. More...
JY6302API int | JY6302_AI_CheckBufferStatusEx (JY6302_DeviceHandle hDevice, unsigned long long *availableSamplesCount, unsigned long long *transferedSamples, bool *overflow)
Check AI device buffer status. More...
JY6302API int | JY6302_AI_SetStartTriggerType (JY6302_DeviceHandle hDevice, JY6302_AI_TriggerType triggerType)
JY6302API int | JY6302_AI_SetDigitalStartTrigger (JY6302_DeviceHandle hDevice, JY6302_IOTerminal triggerSource, JY6302_DigitalTriggerEdge triggerEdge)
Set AI digital start trigger,the triggerSource is defined by enum JY6302_DigitalTriggerSource, the triggerEdge is defined by enum JY6302_DigitalTriggerEdge. More...
JY6302API int | JY6302_AI_SetReferenceTriggerType (JY6302_DeviceHandle hDevice, JY6302_AI_TriggerType triggerType)
Set AI reference trigger type,the triggerType is defined by enum JY6302_AI_TriggerType More...
JY6302API int | JY6302_AI_SetDigitalReferenceTrigger (JY6302_DeviceHandle hDevice, JY6302_IOTerminal triggerSource, JY6302_DigitalTriggerEdge triggerEdge)
Set AI digital reference trigger.the triggerSource is defined by enum JY6302_DigitalTriggerSource, the triggerEdge is defined by enum JY6302_DigitalTriggerEdge. More...
JY6302API int | JY6302_AI_SetAdvanceTriggerType (JY6302_DeviceHandle hDevice, JY6302_AI_TriggerType triggerType)
JY6302API int | JY6302_AI_SetDigitalAdvanceTrigger (JY6302_DeviceHandle hDevice, JY6302_IOTerminal triggerSource, JY6302_DigitalTriggerEdge triggerEdge)
Set AI digital advance trigger,the triggerSource is defined by enum JY6302_DigitalTriggerSource, the triggerEdge is defined by enum JY6302_DigitalTriggerEdge. More...
JY6302API int | JY6302_AI_SetPreTriggerSamples (JY6302_DeviceHandle hDevice, unsigned int preTriggerSamples)
Set AI pretrigger samples, the samples must greater than 0. More...
JY6302API int | JY6302_AI_SetReTriggerCount (JY6302_DeviceHandle hDevice, unsigned int reTriggerCount)
Set AI retrigger count. More...
JY6302API int | JY6302_AI_SendSoftTrigger (JY6302_DeviceHandle hDevice, JY6302_AI_TriggerMode triggerSel)
JY6302API int | JY6302_AI_QueryOnboardRJTemperature (JY6302_DeviceHandle hDevice, unsigned int channelID, double *referenceJunctionTemperature)
Queries the reference Terminals temperature value for the specified physical channel More...
JY6302API int | JY6302_AI_SetUserRJTemperature (JY6302_DeviceHandle hDevice, unsigned int channelIndex, double referenceJunctionTemperature)
Sets user defined reference Terminals temperature value for the specified physical channel. More...
JY6302API int | JY6302_AI_DetectOpenThermocouple (JY6302_DeviceHandle hDevice, int burnout, int samplesToAcquire, int *buf, int timeout)
Perform open circuit detection. More...
JY6302API int | JY6302_AI_SetCJDataSource (JY6302_DeviceHandle hDevice, bool enableUserTmp)
Set cold junction data source.Options:raw data,dejittered data,user-defined data More...
JY6302API int | JY6302_AI_Diagnose (JY6302_DeviceHandle hDevice, int *sampleIgnored)
Run diagnose More...
JY6302API int | JY6302_SignalRouting (JY6302_DeviceHandle hDevice, JY6302_Singnal_Destination destination, JY6302_Signal_Source source)
JY6302API int | JY6302_DisconnectSignalRouting (JY6302_DeviceHandle hDevice, JY6302_Singnal_Destination destination)
JY6302API int | JY6302_EnableCJ (JY6302_DeviceHandle hDevice, int terminalBlockSel, bool enable)
Enable/disable TB68CJ on the specified Connector. More...
JY6302API int | JY6302_GetTerminalBlockConnectionStatus (JY6302_DeviceHandle hDevice, int terminalBlockSel, bool *terminalBlockConnected)
Gets the external TB68CJ connection status More...
JY6302API int | JY6302_SetCJUpdateDataTimeout (JY6302_DeviceHandle hDevice, int timeout)
Sets the timeout for TB68CJ to update data. More...
JY6302API int | JY6302_SetCJUpdateInterval (JY6302_DeviceHandle hDevice, int interval)
Set the TB68CJ data update interval More...
JY6302API int | JY6302_EnableCJDebouncedData (JY6302_DeviceHandle hDevice, bool enable)
Enables the cold junction temperature sensor data to de-jitter the data More...
JY6302API int | JY6302_SetCJMaxBounce (JY6302_DeviceHandle hDevice, double bounceMax)
Set the maximum jitter value allowed when the TB68CJ output data is debounceed, and the amount of change beyond this limit will be forcibly compressed to the maximum jitter value More...
JY6302API int | JY6302_GetCJMaxBounce (JY6302_DeviceHandle hDevice, double *bounceMax)
Gets the maximum jitter value allowed when the TB68CJ current output data is debounceed More...
JY6302API int | JY6302_SetCJInvalidBounce (JY6302_DeviceHandle hDevice, double bounceInvalid)
Set the jitter value(TB68CJ remove jitter is judged to be invalid) More...
JY6302API int | JY6302_GetCJInvalidBounce (JY6302_DeviceHandle hDevice, double *bounceInvalid)
Set the jitter value(TB68CJ remove jitter is judged to be invalid) More...
JY6302API int | JY6302_GetCJDebouncingStatus (JY6302_DeviceHandle hDevice, int terminalBlockSel, bool *isNormal)
Gets the cold-junction data remove jitter state More...
JY6302API int | JY6302_ResetDebouncer (JY6302_DeviceHandle hDevice)
Resets TB68CJ to remove jitter. More...

Detailed Description

@SectionBegin JY6302 FileHead

COPYRIGHT NOTICE
Copyright (c) 2018-2021, JYTEK
All rights reserved.
Author
JYTEK
Version
2.4.0
Date
2022-6-24

This header file defines C/C++ API and enums used in the JY6302 driver.

Revision Notes:

Typedef Documentation

◆ JY6302_DeviceHandle

typedef void* JY6302_DeviceHandle

Windows.

Linux

Enumeration Type Documentation

◆ JY6302_AI_SampleMode

enum JY6302_AI_SampleMode
Enumerator
JY6302_AI_Finite | AI Finite Mode.
JY6302_AI_Continuous | AI Continuous Mode.
JY6302_AI_Single | AI Single Mode.

◆ JY6302_AI_TriggerMode

enum JY6302_AI_TriggerMode
Enumerator
JY6302_AI_Trigger_Start | AI Start Trigger Mode.
JY6302_AI_Trigger_Reference | AI Reference Trigger Mode.
JY6302_AI_Trigger_Advance | AI Advance Trigger Mode.

◆ JY6302_AI_TriggerType

enum JY6302_AI_TriggerType
Enumerator
JY6302_AI_Immediately | AI Immediately Type.
JY6302_AI_Digital | AI Digital Type.
JY6302_AI_Soft | AI Soft Type.

◆ JY6302_AI_VoltageRange

enum JY6302_AI_VoltageRange
Enumerator
JY6302_AI_78125uV | ��78.125mV
JY6302_AI_39062uV | ��39.06mV
JY6302_AI_19531uV | ��19.53mV

◆ JY6302_DigitalTriggerEdge

enum JY6302_DigitalTriggerEdge
Enumerator
JY6302_Rising | AI Rising edge for digital trigger.
JY6302_Falling | AI Falling edge for digital trigger.

◆ JY6302_HJ_Data_Source

enum JY6302_HJ_Data_Source
Enumerator
JY6302_HJ_CONV_DATA
JY6302_HJ_CONV_TIME

◆ JY6302_IOTerminal

enum JY6302_IOTerminal
Enumerator
JY6302_PFI_0 | PFI0 as the terminal.
JY6302_PFI_1 | PFI1 as the terminal.
JY6302_PFI_2 | PFI2 as the terminal.
JY6302_PFI_3 | PFI3 as the terminal.
JY6302_TriggerBus_0 | PXITrigger0 as the terminal.
JY6302_TriggerBus_1 | PXITrigger1 as the terminal.
JY6302_TriggerBus_2 | PXITrigger2 as the terminal.
JY6302_TriggerBus_3 | PXITrigger3 as the terminal.
JY6302_TriggerBus_4 | PXITrigger4 as the terminal.
JY6302_TriggerBus_5 | PXITrigger5 as the terminal.
JY6302_TriggerBus_6 | PXITrigger6 as the terminal.
JY6302_TriggerBus_7 | PXITrigger7 as the terminal.
JY6302_STAR | STAR as the terminal.

◆ JY6302_SampleClockSource

enum JY6302_SampleClockSource
Enumerator
JY6302_InternalSampleClock | AI Internal SampleClock.
JY6302_ExternalSampleClock | AI External SampleClock.

◆ JY6302_Signal_Source

enum JY6302_Signal_Source
Enumerator
JY6302_AI_SampleClock | AI_SampleClock as the source signal to rout.
JY6302_AI_StartTrig | AI_StartTrig as the source signal to rout.
JY6302_AI_ReferenceTrig | AI_ReferenceTrig as the source signal to rout.
JY6302_AI_AdvanceTrig | AI_AdvanceTrig as the source signal to rout.

◆ JY6302_Singnal_Destination

enum JY6302_Singnal_Destination
Enumerator
JY6302_EXPORT_PFI_0 | EXPORT_PFI_0 as the signal desition to rout.
JY6302_EXPORT_PFI_1 | EXPORT_PFI_1 as the signal desition to rout.
JY6302_EXPORT_PFI_2 | EXPORT_PFI_2 as the signal desition to rout.
JY6302_EXPORT_PFI_3 | EXPORT_PFI_3 as the signal desition to rout.
JY6302_EXPORT_TriggerBus_0 | EXPORT_TriggerBus_0 as the signal desition to rout.
JY6302_EXPORT_TriggerBus_1 | EXPORT_TriggerBus_1 as the signal desition to rout.
JY6302_EXPORT_TriggerBus_2 | EXPORT_TriggerBus_2 as the signal desition to rout.
JY6302_EXPORT_TriggerBus_3 | EXPORT_TriggerBus_3 as the signal desition to rout.
JY6302_EXPORT_TriggerBus_4 | EXPORT_TriggerBus_4 as the signal desition to rout.
JY6302_EXPORT_TriggerBus_5 | EXPORT_TriggerBus_5 as the signal desition to rout.
JY6302_EXPORT_TriggerBus_6 | EXPORT_TriggerBus_6 as the signal desition to rout.
JY6302_EXPORT_TriggerBus_7 | EXPORT_TriggerBus_7 as the signal desition to rout.
JY6302_EXPORT_STAR | EXPORT_STAR as the signal desition to rout.

◆ JY6302_ThermocoupleType

enum JY6302_ThermocoupleType
Enumerator
JY6302_TypeR
JY6302_TypeS
JY6302_TypeB
JY6302_TypeJ
JY6302_TypeT
JY6302_TypeE
JY6302_TypeK
JY6302_TypeN
JY6302_TypeC
JY6302_TypeA

Function Documentation

◆ JY6302_AI_CheckBufferStatus()

JY6302API int JY6302_AI_CheckBufferStatus | ( | JY6302_DeviceHandle | hDevice,
 |  | unsigned long long * | availableSamplesCount,
 |  | bool * | overflow
 | ) |  |

Check AI device buffer status.

This API is intended to be compatible with older version drivers. It is recommended to use API JY6302_AI_CheckBufferStatusEx.

Parameters
hDevice | device handle
availableSamplesCount | number of samples per channel in the device buffer
overflow | true��overflow, false��not overflow.
Returns
0 if success or other error code

◆ JY6302_AI_CheckBufferStatusEx()

JY6302API int JY6302_AI_CheckBufferStatusEx | ( | JY6302_DeviceHandle | hDevice,
 |  | unsigned long long * | availableSamplesCount,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overflow
 | ) |  |

Check AI device buffer status.

Parameters
hDevice | device handle
availableSamplesCount | number of samples per channel in the device buffer
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overflow | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY6302_AI_DetectOpenThermocouple()

JY6302API int JY6302_AI_DetectOpenThermocouple | ( | JY6302_DeviceHandle | hDevice,
 |  | int | burnout,
 |  | int | samplesToAcquire,
 |  | int * | buf,
 |  | int | timeout
 | ) |  |

Perform open circuit detection.

Parameters
hDevice | device handle
burnout | Excitation current selection
samplesToAcquire | The number of samples to be sampled
buf | conversion result(array), the length of which matches the number of channels. Reading near full-scale (0xFFFFFF) may mean that the front-end sensor is open, overloaded, or missing a reference, and the lack of reference voltage is also reflected in the convError corresponding to the bit of 1; If the conversion result is 0, it may be a short circuit to the sensor
timeout | read data timeout
Returns
0 if success or other error code

◆ JY6302_AI_Diagnose()

JY6302API int JY6302_AI_Diagnose | ( | JY6302_DeviceHandle | hDevice,
 |  | int * | sampleIgnored
 | ) |  |

Run diagnose

Parameters
hDevice | device handle
sampleIgnored | Wether the sample signal has ever been ignored.
Returns
0 if success or other error code

◆ JY6302_AI_EnableChannel()

JY6302API int JY6302_AI_EnableChannel | ( | JY6302_DeviceHandle | hDevice,
 |  | unsigned int | channelsCount,
 |  | unsigned int * | channelsIndex,
 |  | JY6302_AI_VoltageRange * | inputVoltageRange,
 |  | JY6302_ThermocoupleType * | thermocoupleType
 | ) |  |

Enable AI channels.

Each channel can be independently configured

Parameters
hDevice | device handle
channelCount | number of channels to be enabled

param name="channelsIndex">Physical serial number of the array[channelCount]

Parameters
inputVoltageRange | Input voltage range
thermocoupleType | thermocouple Type
Returns
0 if success or other error code

◆ JY6302_AI_EnableCJUserData()

JY6302API int JY6302_AI_EnableCJUserData | ( | JY6302_DeviceHandle | hDevice,
 |  | bool | enable
 | ) |  |

Enable/disable user-defined cold junction temperatures

Parameters
hDevice | device handle
enable | Enable/disable flag
Returns
0 if success or other error code

◆ JY6302_AI_EnableNonTCMode()

JY6302API int JY6302_AI_EnableNonTCMode | ( | JY6302_DeviceHandle | hDevice,
 |  | bool | enable
 | ) |  |

Enables/disables Non-thermocouple voltage signal measurement mode.

In this mode, VBIAS for all channels will be forcibly disabled.

Parameters
hDevice | device handle
enable | Enable/disable flag
Returns
0 if success or other error code

◆ JY6302_AI_GetActualSampleRate()

JY6302API int JY6302_AI_GetActualSampleRate | ( | double | sampleRate,
 |  | int | REJ60,
 |  | unsigned int * | chIndex,
 |  | unsigned int | chCount,
 |  | double * | actualSampleRate,
 |  | int * | powerLineRejEnabled
 | ) |  |

summary> Gets the actual desirable sample rate and conversion rate /summary> param name="sampleRate">up to 800Sa/s can be set on each AD chip

param name="convertRateIndex">conversion rate index which can be Level0/Level1/Level2/Level3/Level4/Level5, when -1, the function will select the lowest conversion rate possible to achieve optimal noise suppression under the premise of prioritizing the required sample rate. The conversion rate and the maximum number of channels on a single chip together limit the maximum sample rate.

param name="sampleClkSrc">sample clock source. when external sample clock, an error is returned when the sample rate cannot actually be set to the required sample rate because the sample rate cannot be adjusted.

param name="topology">channel topology

param name="chnsIndex">The physical index value of all currently enabled channels

param name="chnsCount">The channel count of all currently enabled channels

param name="actualSampleRate">actual sampling rate set by this device,which may be different from the desired sampleRate

param name="actualConvertRate">actual convert rate set by this device, which may be different from the desired convertRate, the reciprocal of the time required for each AD conversion. The higher the conversion rate, the greater the noise

Returns
0 if success or other error code

◆ JY6302_AI_QueryOnboardRJTemperature()

JY6302API int JY6302_AI_QueryOnboardRJTemperature | ( | JY6302_DeviceHandle | hDevice,
 |  | unsigned int | channelID,
 |  | double * | referenceJunctionTemperature
 | ) |  |

Queries the reference Terminals temperature value for the specified physical channel

Parameters
hDevice | device handle
channelID | The physical serial number of the channel to query
referenceJunctionTemperature | The reference Terminals temperature value of the channel(��)
Returns
0 if success or other error code

◆ JY6302_AI_ReadData()

JY6302API int JY6302_AI_ReadData | ( | JY6302_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeout,
 |  | unsigned int * | actualReadLength
 | ) |  |

The acquisition data of the measuring and the reference are read at the same time, and the cold is compensated and converted to temperature���棩

Parameters
hDevice | device handle
dataBuffer | returns the acquired data (array)
dataLength | The length of the data to read
timeout | read data timeout, when -1,never times out.unit:ms
actualReadLength | returns the actual length of the data read
Returns
0 if success or other error code

◆ JY6302_AI_ReadMeasuringJuctionData()

JY6302API int JY6302_AI_ReadMeasuringJuctionData | ( | JY6302_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeout,
 |  | unsigned int * | actualReadLength
 | ) |  |

summary> Read Measuring Juction data /summary> param name="hDevice">device handle

param name="dataBuffer">returns the acquired data that has been calibrated

param name="dataLength">The length of the data to read

param name="timeOut">read data timeout, when -1,never times out.unit:ms

param name="actualReadLength">returns the actual length of the data read

Returns
0 if success or other error code

◆ JY6302_AI_ReadMeasuringJuctionRawData()

JY6302API int JY6302_AI_ReadMeasuringJuctionRawData | ( | JY6302_DeviceHandle | hDevice,
 |  | int * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength
 | ) |  |

summary> Read Measuring Juction Raw data /summary> param name="hDevice">device handle

param name="dataBuffer">returns the acquisition data that has been calibrated for gain and offset

param name="dataLength">The length of the data to read

param name="timeOut">read data timeout, when -1,never times out.unit:ms

param name="actualReadLength">returns the actual length of the data read

Returns
0 if success or other error code

◆ JY6302_AI_ReadMeasuringJunctionSinglePoint()

JY6302API int JY6302_AI_ReadMeasuringJunctionSinglePoint | ( | JY6302_DeviceHandle | hDevice,
 |  | double * | dataBuffer
 | ) |  |

summary> Read single point data of all enabled channels. Available when the acquisition mode is Single mode. /summary> param name="hDevice">device handle

param name="dataBuffer">returns the acquired data (array) with the same length of the buffer as the number of enabled channels

Returns
0 if success or other error code

◆ JY6302_AI_ReadReferenceJunctionData()

JY6302API int JY6302_AI_ReadReferenceJunctionData | ( | JY6302_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeout,
 |  | unsigned int * | actualReadLength
 | ) |  |

Read Measuring Reference Juction data(��)

Parameters
hDevice | device handle
dataBuffer | returns the acquired data (array)

param name="dataLength">The length of the data to read

param name="timeOut">read data timeout, when -1,never times out.unit:ms

param name="actualReadLength">returns the actual length of the data read

Returns
0 if success or other error code

◆ JY6302_AI_ReadReferenceJunctionRawData()

JY6302API int JY6302_AI_ReadReferenceJunctionRawData | ( | JY6302_DeviceHandle | hDevice,
 |  | short * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeout,
 |  | unsigned int * | actualReadLength
 | ) |  |

Read Measuring Reference Juction Raw data

Parameters
hDevice | device handle
dataBuffer | returns the acquired Raw data (array)��This value is multiplied by 0.0078125 to be the actual temperature(��)

param name="dataLength">The length of the data to read

param name="timeOut">read data timeout, when -1,never times out.unit:ms

param name="actualReadLength">returns the actual length of the data read

Returns
0 if success or other error code

◆ JY6302_AI_ReadReferenceJunctionSinglePoint()

JY6302API int JY6302_AI_ReadReferenceJunctionSinglePoint | ( | JY6302_DeviceHandle | hDevice,
 |  | double * | dataBuffer
 | ) |  |

summary> Read Measuring Reference Juction single point data of all enabled channels. Available when the acquisition mode is Single mode. /summary> param name="hDevice">device handle

param name="dataBuffer">returns the acquired data (array) with the same length of the buffer as the number of enabled channels

Returns
0 if success or other error code

◆ JY6302_AI_ReadSinglePoint()

JY6302API int JY6302_AI_ReadSinglePoint | ( | JY6302_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | int | channelID
 | ) |  |

The unbuffered single point reads the acquisition data of both the measuring and reference, and the cold junction compensates for it and converts it to temperature

Parameters
hDevice | device handle
dataBuffer | returns the acquired data (array)
channelID | read the specified channelID. when the channelID is -1, read all enabled channels value.
Returns
0 if success or other error code

◆ JY6302_AI_SendSoftTrigger()

JY6302API int JY6302_AI_SendSoftTrigger | ( | JY6302_DeviceHandle | hDevice,
 |  | JY6302_AI_TriggerMode | triggerSel
 | ) |  |

summary> Send software trigger /summary> param name="hDevice">device handle

param name="triggerMode">software trigger mode.Options:start trigger mode,reference trigger mode,advance trigger mode

Returns
0 if success or other error code

◆ JY6302_AI_SetAdvanceTriggerType()

JY6302API int JY6302_AI_SetAdvanceTriggerType | ( | JY6302_DeviceHandle | hDevice,
 |  | JY6302_AI_TriggerType | triggerType
 | ) |  |

summary> Set AI advance trigger type,the triggerType is defined by enum JY6302_AI_TriggerType. /summary> param name="hDevice">device handle

param name="triggerType">advance trigger type.Options: immediate trigger, software trigger, digital trigger or analog trigger.

Returns
0 if success or other error code

◆ JY6302_AI_SetCJDataSource()

JY6302API int JY6302_AI_SetCJDataSource | ( | JY6302_DeviceHandle | hDevice,
 |  | bool | enableUserTmp
 | ) |  |

Set cold junction data source.Options:raw data,dejittered data,user-defined data

Parameters
hDevice | device handle
enableUserTmp | Enable/disable user data
Returns
0 if success or other error code

◆ JY6302_AI_SetDigitalAdvanceTrigger()

JY6302API int JY6302_AI_SetDigitalAdvanceTrigger | ( | JY6302_DeviceHandle | hDevice,
 |  | JY6302_IOTerminal | triggerSource,
 |  | JY6302_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set AI digital advance trigger,the triggerSource is defined by enum JY6302_DigitalTriggerSource, the triggerEdge is defined by enum JY6302_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI digital advance trigger source
triggerEdge | AI digital advance trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

summary>

◆ JY6302_AI_SetDigitalReferenceTrigger()

JY6302API int JY6302_AI_SetDigitalReferenceTrigger | ( | JY6302_DeviceHandle | hDevice,
 |  | JY6302_IOTerminal | triggerSource,
 |  | JY6302_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set AI digital reference trigger.the triggerSource is defined by enum JY6302_DigitalTriggerSource, the triggerEdge is defined by enum JY6302_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI reference trigger source
triggerEdge | AI reference to the trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY6302_AI_SetDigitalStartTrigger()

JY6302API int JY6302_AI_SetDigitalStartTrigger | ( | JY6302_DeviceHandle | hDevice,
 |  | JY6302_IOTerminal | triggerSource,
 |  | JY6302_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set AI digital start trigger,the triggerSource is defined by enum JY6302_DigitalTriggerSource, the triggerEdge is defined by enum JY6302_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI digital start trigger source
triggerEdge | AI digital start trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY6302_AI_SetExternalSampleClockTerminal()

JY6302API int JY6302_AI_SetExternalSampleClockTerminal | ( | JY6302_DeviceHandle | hDevice,
 |  | JY6302_IOTerminal | extSampleClkSrc
 | ) |  |

summary> Set AI external sample clock terminal /summary> param name="hDevice">device handle

param name="extSampleClkSrc">external sample clock terminal

Returns
0 if success or other error code

◆ JY6302_AI_SetPreTriggerSamples()

JY6302API int JY6302_AI_SetPreTriggerSamples | ( | JY6302_DeviceHandle | hDevice,
 |  | unsigned int | preTriggerSamples
 | ) |  |

Set AI pretrigger samples, the samples must greater than 0.

Parameters
hDevice | device handle
preTriggerSamples | AI pretrigger samples, valid only in reference trigger mode.
Returns
0 if success or other error code

◆ JY6302_AI_SetReferenceTriggerType()

JY6302API int JY6302_AI_SetReferenceTriggerType | ( | JY6302_DeviceHandle | hDevice,
 |  | JY6302_AI_TriggerType | triggerType
 | ) |  |

Set AI reference trigger type,the triggerType is defined by enum JY6302_AI_TriggerType

Parameters
hDevice | device handle
triggerType | AI reference trigger type.Options: immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if success or other error code

◆ JY6302_AI_SetReTriggerCount()

JY6302API int JY6302_AI_SetReTriggerCount | ( | JY6302_DeviceHandle | hDevice,
 |  | unsigned int | reTriggerCount
 | ) |  |

Set AI retrigger count.

The device will be triggered reTriggerCount times.

Parameters
hDevice | device handle
reTriggerCount | AI retrigger count
Returns
0 if success or other error code

◆ JY6302_AI_SetSampleMode()

JY6302API int JY6302_AI_SetSampleMode | ( | JY6302_DeviceHandle | hDevice,
 |  | JY6302_AI_SampleMode | mode
 | ) |  |

summary> Set sample mode /summary> param name="hDevice">device handle

param name="mode">sample mode(JY6302_AI_Finite/JY6302_AI_Continuous/JY6302_AI_Single)

Returns
0 if success or other error code

◆ JY6302_AI_SetSampleRate()

JY6302API int JY6302_AI_SetSampleRate | ( | JY6302_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | int | REJ60,
 |  | JY6302_SampleClockSource | sampleClkSrc,
 |  | double * | actualSampleRate,
 |  | int * | powerLineRejEnabled
 | ) |  |

summary> Set sampling rate. The sampling rate is the same for all channels. /summary> param name="hDevice">device handle

param name="sampleRate">up to 800Sa/s can be set on each AD chip

param name="REJ60">0: prefer 50Hz power line rejection. 1: prefer 60Hz power line rejection. Valid when the total sampling rate is less than or equal to 40Sa/s.

param name="sampleClkSrc">sample clock source.

param name="actualSampleRate">actual sampling rate set by this device,which may be different from the desired sampleRate

param name="powerLineRejEnabled">wether power line rejection enabled

Returns
0 if success or other error code

◆ JY6302_AI_SetSamplesToAcquire()

JY6302API int JY6302_AI_SetSamplesToAcquire | ( | JY6302_DeviceHandle | hDevice,
 |  | unsigned int | samplesToAcquire
 | ) |  |

summary> Set AI samples to acquire for each channel in finite mode. /summary> param name="hDevice">device handle

param name="samplesToAcquire">AI finite samples to acquire for each channel

Returns
0 if success or other error code

◆ JY6302_AI_SetStartTriggerType()

JY6302API int JY6302_AI_SetStartTriggerType | ( | JY6302_DeviceHandle | hDevice,
 |  | JY6302_AI_TriggerType | triggerType
 | ) |  |

summary> Set AI start tigger type,the triggerType is defined by enum JY6302_AI_TriggerType /summary> param name="hDevice">device handle

param name="triggerType">start tigger type(Options:immediate trigger/digital trigger/analog trigger/software trigger)

Returns
0 if success or other error code

◆ JY6302_AI_SetUserRJTemperature()

JY6302API int JY6302_AI_SetUserRJTemperature | ( | JY6302_DeviceHandle | hDevice,
 |  | unsigned int | channelIndex,
 |  | double | referenceJunctionTemperature
 | ) |  |

Sets user defined reference Terminals temperature value for the specified physical channel.

Valid only if CJDataSource is User Data

Parameters
hDevice | device handle
channelID | The physical serial number of the channel to query
referenceJunctionTemperature | The reference Terminals temperature value of the channel(��)
Returns
0 if success or other error code

◆ JY6302_AI_Start()

JY6302API int JY6302_AI_Start ( JY6302_DeviceHandle hDevice )

summary> Start AI acquisition. /summary> param name="hDevice">device handle

Returns
0 if success or other error code

◆ JY6302_AI_Stop()

JY6302API int JY6302_AI_Stop ( JY6302_DeviceHandle hDevice )

summary> stop AI acquisition. /summary> param name="hDevice">device handle

Returns
0 if success or other error code

◆ JY6302_AI_WaitUntilDone()

JY6302API int JY6302_AI_WaitUntilDone | ( | JY6302_DeviceHandle | hDevice,
 |  | int | timeout,
 |  | bool * | done
 | ) |  |

summary> Check that the finite point acquisition is complete /summary> param name="hDevice">device handle

param name="timeout">timeout unit��ms

param name="done">returns whether the finite point acquisition is complete(true/false)

Returns
0 if success or other error code

◆ JY6302_Close()

JY6302API int JY6302_Close ( JY6302_DeviceHandle hDevice )

Close this 6302 board.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY6302_DisconnectSignalRouting()

JY6302API int JY6302_DisconnectSignalRouting | ( | JY6302_DeviceHandle | hDevice,
 |  | JY6302_Singnal_Destination | destination
 | ) |  |

summary> Disconnects the specified port and the internal signal,resets to a low level /summary> param name="hDevice">device handle

param name="destination">destination terminal

Returns
0 if success or other error code

◆ JY6302_EnableCJ()

JY6302API int JY6302_EnableCJ | ( | JY6302_DeviceHandle | hDevice,
 |  | int | terminalBlockSel,
 |  | bool | enable
 | ) |  |

Enable/disable TB68CJ on the specified Connector.

When disabled, the 6302 does not initiate I2C traffic

Parameters
hDevice | device handle
terminalBlockSel | Connector select(0 - Right,1 - Left)
enable | Enable/Disable flag
Returns
0 if success or other error code

◆ JY6302_EnableCJDebouncedData()

JY6302API int JY6302_EnableCJDebouncedData | ( | JY6302_DeviceHandle | hDevice,
 |  | bool | enable
 | ) |  |

Enables the cold junction temperature sensor data to de-jitter the data

Parameters
hDevice | device handle
enable | Enable/disable flag
Returns
0 if success or other error code

◆ JY6302_GetCJDebouncingStatus()

JY6302API int JY6302_GetCJDebouncingStatus | ( | JY6302_DeviceHandle | hDevice,
 |  | int | terminalBlockSel,
 |  | bool * | isNormal
 | ) |  |

Gets the cold-junction data remove jitter state

Parameters
hDevice | device handle
terminalBlockSel | Connector select. 0: Connector0(Right); 1: Connector1(Left)
isNormal | normal/abnormal flag
Returns
0 if success or other error code

◆ JY6302_GetCJInvalidBounce()

JY6302API int JY6302_GetCJInvalidBounce | ( | JY6302_DeviceHandle | hDevice,
 |  | double * | bounceInvalid
 | ) |  |

Set the jitter value(TB68CJ remove jitter is judged to be invalid)

Parameters
hDevice | device handle
bounceInvalid | Invalid jitter value(��)
Returns
0 if success or other error code

◆ JY6302_GetCJMaxBounce()

JY6302API int JY6302_GetCJMaxBounce | ( | JY6302_DeviceHandle | hDevice,
 |  | double * | bounceMax
 | ) |  |

Gets the maximum jitter value allowed when the TB68CJ current output data is debounceed

Parameters
hDevice | device handle
bounceMax | Maximum jitter value,unit:��
Returns
0 if success or other error code

◆ JY6302_GetDeviceID()

JY6302API int JY6302_GetDeviceID | ( | JY6302_DeviceHandle | hDevice,
 |  | int * | deviceID
 | ) |  |

Obtain the board ID.

The 6302 is a series of boards. The PXIe-6302 board ID is Ox6302 The PCIe-6302 board ID is OxA302 The USB-6302 board ID is OxB302

Parameters
hDevice | device handle
deviceID | board ID
Returns
0 if success or other error code

◆ JY6302_GetDeviceSerialNumber()

JY6302API int JY6302_GetDeviceSerialNumber | ( | JY6302_DeviceHandle | hDevice,
 |  | char * | serialNumber,
 |  | int | length
 | ) |  |

Obtain the device serialNumber

Parameters
hDevice | device handle
serialNumber | Pointer to a buffer receiving the serial number.The length of the serial number is 10.
length | serial Number length,length is 10
Returns
0 if success or other error code

◆ JY6302_GetTerminalBlockConnectionStatus()

JY6302API int JY6302_GetTerminalBlockConnectionStatus | ( | JY6302_DeviceHandle | hDevice,
 |  | int | terminalBlockSel,
 |  | bool * | terminalBlockConnected
 | ) |  |

Gets the external TB68CJ connection status

Parameters
hDevice | device handle
terminalBlockSel | Connector select. 0: Connector0(Right); 1: Connector1(Left)
terminalBlockConnected | Whether the Connector is connected to TB68CJ
Returns
0 if success or other error code

◆ JY6302_Open()

JY6302API int JY6302_Open | ( | int | slotNumber,
 |  | JY6302_DeviceHandle * | hDevice
 | ) |  |

Open the 6302 series boards using the slot number or the board serial number.

PXIe slot number is predefined by the PXIe chassis. PCIe slot number is defined by the DIP switch. The board serial number is defined by the system starting from 0. It's your responsibility to know the number. For a single board, the serial number is 0.

Parameters
slotNumber | slot number or board serial number
hDevice | device handle. All other functions uses hDevice to represent this device.
Returns
0 if success or other error code

◆ JY6302_OpenByName()

JY6302API int JY6302_OpenByName | ( | const char * | cardName,
 |  | JY6302_DeviceHandle * | hDevice
 | ) |  |

Open this 6302 series boards using the board alias name which is set by JYTEK utility JYDM.

You can change the name using JYDM.

Parameters
cardName | board alias name
hDevice | device handle
Returns
0 if success or other error code

◆ JY6302_ResetDebouncer()

JY6302API int JY6302_ResetDebouncer ( JY6302_DeviceHandle hDevice )

Resets TB68CJ to remove jitter.

After the reset, you need to wait at least 1 second to generate valid data

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY6302_SetCJInvalidBounce()

JY6302API int JY6302_SetCJInvalidBounce | ( | JY6302_DeviceHandle | hDevice,
 |  | double | bounceInvalid
 | ) |  |

Set the jitter value(TB68CJ remove jitter is judged to be invalid)

Parameters
hDevice | device handle
bounceInvalid | Invalid jitter value (��C), must be greater than 0 and less than or equal to 100. Integer division error occurs when not an integer multiple of 0.0078125
Returns
0 if success or other error code

◆ JY6302_SetCJMaxBounce()

JY6302API int JY6302_SetCJMaxBounce | ( | JY6302_DeviceHandle | hDevice,
 |  | double | bounceMax
 | ) |  |

Set the maximum jitter value allowed when the TB68CJ output data is debounceed, and the amount of change beyond this limit will be forcibly compressed to the maximum jitter value

Parameters
hDevice | device handle
bounceMax | The maximum jitter value��unit:�档Integer division error occurs when not an integer multiple of 0.0078125
Returns
0 if success or other error code

◆ JY6302_SetCJUpdateDataTimeout()

JY6302API int JY6302_SetCJUpdateDataTimeout | ( | JY6302_DeviceHandle | hDevice,
 |  | int | timeout
 | ) |  |

Sets the timeout for TB68CJ to update data.

When the data is not updated beyond this time, the corresponding error flag register will be set.

Parameters
hDevice | device handle
timeout | Timeout unit:ms. Since the I2C communication itself takes less than 1ms, there is a certain error in the timeout.
Returns
0 if success or other error code

◆ JY6302_SetCJUpdateInterval()

JY6302API int JY6302_SetCJUpdateInterval | ( | JY6302_DeviceHandle | hDevice,
 |  | int | interval
 | ) |  |

Set the TB68CJ data update interval

Parameters
hDevice | device handle
timeout | Update interval unit:ms.
Returns
0 if success or other error code

◆ JY6302_SignalRouting()

JY6302API int JY6302_SignalRouting | ( | JY6302_DeviceHandle | hDevice,
 |  | JY6302_Singnal_Destination | destination,
 |  | JY6302_Signal_Source | source
 | ) |  |

summary> Exports the internal signal to the specified port /summary> param name="hDevice">device handle

param name="destination">destination terminal

param name="source">source terminal

Returns
0 if success or other error code


6302 C++ Programming Manual: D:/6302 Directory Reference

  • D:
  • 6302
6302 Directory Reference

Directories

directory Cpp


6302 C++ Programming Manual: D: Directory Reference

  • D:
D: Directory Reference

Directories

directory 6302


6302 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 1234]
▼ D: |
▼ 6302 |
▼ Cpp |
JY6302.h | @SectionBegin JY6302 FileHead


6302 C++ Programming Manual: File Members

Here is a list of all file members with links to the files they belong to:

- j -

  • JY6302_AI_19531uV : JY6302.h
  • JY6302_AI_39062uV : JY6302.h
  • JY6302_AI_78125uV : JY6302.h
  • JY6302_AI_AdvanceTrig : JY6302.h
  • JY6302_AI_CheckBufferStatus() : JY6302.h
  • JY6302_AI_CheckBufferStatusEx() : JY6302.h
  • JY6302_AI_Continuous : JY6302.h
  • JY6302_AI_DetectOpenThermocouple() : JY6302.h
  • JY6302_AI_Diagnose() : JY6302.h
  • JY6302_AI_Digital : JY6302.h
  • JY6302_AI_EnableChannel() : JY6302.h
  • JY6302_AI_EnableCJUserData() : JY6302.h
  • JY6302_AI_EnableNonTCMode() : JY6302.h
  • JY6302_AI_Finite : JY6302.h
  • JY6302_AI_GetActualSampleRate() : JY6302.h
  • JY6302_AI_Immediately : JY6302.h
  • JY6302_AI_QueryOnboardRJTemperature() : JY6302.h
  • JY6302_AI_ReadData() : JY6302.h
  • JY6302_AI_ReadMeasuringJuctionData() : JY6302.h
  • JY6302_AI_ReadMeasuringJuctionRawData() : JY6302.h
  • JY6302_AI_ReadMeasuringJunctionSinglePoint() : JY6302.h
  • JY6302_AI_ReadReferenceJunctionData() : JY6302.h
  • JY6302_AI_ReadReferenceJunctionRawData() : JY6302.h
  • JY6302_AI_ReadReferenceJunctionSinglePoint() : JY6302.h
  • JY6302_AI_ReadSinglePoint() : JY6302.h
  • JY6302_AI_ReferenceTrig : JY6302.h
  • JY6302_AI_SampleClock : JY6302.h
  • JY6302_AI_SampleMode : JY6302.h
  • JY6302_AI_SendSoftTrigger() : JY6302.h
  • JY6302_AI_SetAdvanceTriggerType() : JY6302.h
  • JY6302_AI_SetCJDataSource() : JY6302.h
  • JY6302_AI_SetDigitalAdvanceTrigger() : JY6302.h
  • JY6302_AI_SetDigitalReferenceTrigger() : JY6302.h
  • JY6302_AI_SetDigitalStartTrigger() : JY6302.h
  • JY6302_AI_SetExternalSampleClockTerminal() : JY6302.h
  • JY6302_AI_SetPreTriggerSamples() : JY6302.h
  • JY6302_AI_SetReferenceTriggerType() : JY6302.h
  • JY6302_AI_SetReTriggerCount() : JY6302.h
  • JY6302_AI_SetSampleMode() : JY6302.h
  • JY6302_AI_SetSampleRate() : JY6302.h
  • JY6302_AI_SetSamplesToAcquire() : JY6302.h
  • JY6302_AI_SetStartTriggerType() : JY6302.h
  • JY6302_AI_SetUserRJTemperature() : JY6302.h
  • JY6302_AI_Single : JY6302.h
  • JY6302_AI_Soft : JY6302.h
  • JY6302_AI_Start() : JY6302.h
  • JY6302_AI_StartTrig : JY6302.h
  • JY6302_AI_Stop() : JY6302.h
  • JY6302_AI_Trigger_Advance : JY6302.h
  • JY6302_AI_Trigger_Reference : JY6302.h
  • JY6302_AI_Trigger_Start : JY6302.h
  • JY6302_AI_TriggerMode : JY6302.h
  • JY6302_AI_TriggerType : JY6302.h
  • JY6302_AI_VoltageRange : JY6302.h
  • JY6302_AI_WaitUntilDone() : JY6302.h
  • JY6302_Close() : JY6302.h
  • JY6302_DeviceHandle : JY6302.h
  • JY6302_DigitalTriggerEdge : JY6302.h
  • JY6302_DisconnectSignalRouting() : JY6302.h
  • JY6302_EnableCJ() : JY6302.h
  • JY6302_EnableCJDebouncedData() : JY6302.h
  • JY6302_EXPORT_PFI_0 : JY6302.h
  • JY6302_EXPORT_PFI_1 : JY6302.h
  • JY6302_EXPORT_PFI_2 : JY6302.h
  • JY6302_EXPORT_PFI_3 : JY6302.h
  • JY6302_EXPORT_STAR : JY6302.h
  • JY6302_EXPORT_TriggerBus_0 : JY6302.h
  • JY6302_EXPORT_TriggerBus_1 : JY6302.h
  • JY6302_EXPORT_TriggerBus_2 : JY6302.h
  • JY6302_EXPORT_TriggerBus_3 : JY6302.h
  • JY6302_EXPORT_TriggerBus_4 : JY6302.h
  • JY6302_EXPORT_TriggerBus_5 : JY6302.h
  • JY6302_EXPORT_TriggerBus_6 : JY6302.h
  • JY6302_EXPORT_TriggerBus_7 : JY6302.h
  • JY6302_ExternalSampleClock : JY6302.h
  • JY6302_Falling : JY6302.h
  • JY6302_GetCJDebouncingStatus() : JY6302.h
  • JY6302_GetCJInvalidBounce() : JY6302.h
  • JY6302_GetCJMaxBounce() : JY6302.h
  • JY6302_GetDeviceID() : JY6302.h
  • JY6302_GetDeviceSerialNumber() : JY6302.h
  • JY6302_GetTerminalBlockConnectionStatus() : JY6302.h
  • JY6302_HJ_CONV_DATA : JY6302.h
  • JY6302_HJ_CONV_TIME : JY6302.h
  • JY6302_HJ_Data_Source : JY6302.h
  • JY6302_InternalSampleClock : JY6302.h
  • JY6302_IOTerminal : JY6302.h
  • JY6302_Open() : JY6302.h
  • JY6302_OpenByName() : JY6302.h
  • JY6302_PFI_0 : JY6302.h
  • JY6302_PFI_1 : JY6302.h
  • JY6302_PFI_2 : JY6302.h
  • JY6302_PFI_3 : JY6302.h
  • JY6302_ResetDebouncer() : JY6302.h
  • JY6302_Rising : JY6302.h
  • JY6302_SampleClockSource : JY6302.h
  • JY6302_SetCJInvalidBounce() : JY6302.h
  • JY6302_SetCJMaxBounce() : JY6302.h
  • JY6302_SetCJUpdateDataTimeout() : JY6302.h
  • JY6302_SetCJUpdateInterval() : JY6302.h
  • JY6302_Signal_Source : JY6302.h
  • JY6302_SignalRouting() : JY6302.h
  • JY6302_Singnal_Destination : JY6302.h
  • JY6302_STAR : JY6302.h
  • JY6302_ThermocoupleType : JY6302.h
  • JY6302_TriggerBus_0 : JY6302.h
  • JY6302_TriggerBus_1 : JY6302.h
  • JY6302_TriggerBus_2 : JY6302.h
  • JY6302_TriggerBus_3 : JY6302.h
  • JY6302_TriggerBus_4 : JY6302.h
  • JY6302_TriggerBus_5 : JY6302.h
  • JY6302_TriggerBus_6 : JY6302.h
  • JY6302_TriggerBus_7 : JY6302.h
  • JY6302_TypeA : JY6302.h
  • JY6302_TypeB : JY6302.h
  • JY6302_TypeC : JY6302.h
  • JY6302_TypeE : JY6302.h
  • JY6302_TypeJ : JY6302.h
  • JY6302_TypeK : JY6302.h
  • JY6302_TypeN : JY6302.h
  • JY6302_TypeR : JY6302.h
  • JY6302_TypeS : JY6302.h
  • JY6302_TypeT : JY6302.h


6302 C++ Programming Manual: File Members

  • JY6302_AI_SampleMode : JY6302.h
  • JY6302_AI_TriggerMode : JY6302.h
  • JY6302_AI_TriggerType : JY6302.h
  • JY6302_AI_VoltageRange : JY6302.h
  • JY6302_DigitalTriggerEdge : JY6302.h
  • JY6302_HJ_Data_Source : JY6302.h
  • JY6302_IOTerminal : JY6302.h
  • JY6302_SampleClockSource : JY6302.h
  • JY6302_Signal_Source : JY6302.h
  • JY6302_Singnal_Destination : JY6302.h
  • JY6302_ThermocoupleType : JY6302.h


6302 C++ Programming Manual: File Members

- j -

  • JY6302_AI_19531uV : JY6302.h
  • JY6302_AI_39062uV : JY6302.h
  • JY6302_AI_78125uV : JY6302.h
  • JY6302_AI_AdvanceTrig : JY6302.h
  • JY6302_AI_Continuous : JY6302.h
  • JY6302_AI_Digital : JY6302.h
  • JY6302_AI_Finite : JY6302.h
  • JY6302_AI_Immediately : JY6302.h
  • JY6302_AI_ReferenceTrig : JY6302.h
  • JY6302_AI_SampleClock : JY6302.h
  • JY6302_AI_Single : JY6302.h
  • JY6302_AI_Soft : JY6302.h
  • JY6302_AI_StartTrig : JY6302.h
  • JY6302_AI_Trigger_Advance : JY6302.h
  • JY6302_AI_Trigger_Reference : JY6302.h
  • JY6302_AI_Trigger_Start : JY6302.h
  • JY6302_EXPORT_PFI_0 : JY6302.h
  • JY6302_EXPORT_PFI_1 : JY6302.h
  • JY6302_EXPORT_PFI_2 : JY6302.h
  • JY6302_EXPORT_PFI_3 : JY6302.h
  • JY6302_EXPORT_STAR : JY6302.h
  • JY6302_EXPORT_TriggerBus_0 : JY6302.h
  • JY6302_EXPORT_TriggerBus_1 : JY6302.h
  • JY6302_EXPORT_TriggerBus_2 : JY6302.h
  • JY6302_EXPORT_TriggerBus_3 : JY6302.h
  • JY6302_EXPORT_TriggerBus_4 : JY6302.h
  • JY6302_EXPORT_TriggerBus_5 : JY6302.h
  • JY6302_EXPORT_TriggerBus_6 : JY6302.h
  • JY6302_EXPORT_TriggerBus_7 : JY6302.h
  • JY6302_ExternalSampleClock : JY6302.h
  • JY6302_Falling : JY6302.h
  • JY6302_HJ_CONV_DATA : JY6302.h
  • JY6302_HJ_CONV_TIME : JY6302.h
  • JY6302_InternalSampleClock : JY6302.h
  • JY6302_PFI_0 : JY6302.h
  • JY6302_PFI_1 : JY6302.h
  • JY6302_PFI_2 : JY6302.h
  • JY6302_PFI_3 : JY6302.h
  • JY6302_Rising : JY6302.h
  • JY6302_STAR : JY6302.h
  • JY6302_TriggerBus_0 : JY6302.h
  • JY6302_TriggerBus_1 : JY6302.h
  • JY6302_TriggerBus_2 : JY6302.h
  • JY6302_TriggerBus_3 : JY6302.h
  • JY6302_TriggerBus_4 : JY6302.h
  • JY6302_TriggerBus_5 : JY6302.h
  • JY6302_TriggerBus_6 : JY6302.h
  • JY6302_TriggerBus_7 : JY6302.h
  • JY6302_TypeA : JY6302.h
  • JY6302_TypeB : JY6302.h
  • JY6302_TypeC : JY6302.h
  • JY6302_TypeE : JY6302.h
  • JY6302_TypeJ : JY6302.h
  • JY6302_TypeK : JY6302.h
  • JY6302_TypeN : JY6302.h
  • JY6302_TypeR : JY6302.h
  • JY6302_TypeS : JY6302.h
  • JY6302_TypeT : JY6302.h


6302 C++ Programming Manual: File Members

- j -

  • JY6302_AI_CheckBufferStatus() : JY6302.h
  • JY6302_AI_CheckBufferStatusEx() : JY6302.h
  • JY6302_AI_DetectOpenThermocouple() : JY6302.h
  • JY6302_AI_Diagnose() : JY6302.h
  • JY6302_AI_EnableChannel() : JY6302.h
  • JY6302_AI_EnableCJUserData() : JY6302.h
  • JY6302_AI_EnableNonTCMode() : JY6302.h
  • JY6302_AI_GetActualSampleRate() : JY6302.h
  • JY6302_AI_QueryOnboardRJTemperature() : JY6302.h
  • JY6302_AI_ReadData() : JY6302.h
  • JY6302_AI_ReadMeasuringJuctionData() : JY6302.h
  • JY6302_AI_ReadMeasuringJuctionRawData() : JY6302.h
  • JY6302_AI_ReadMeasuringJunctionSinglePoint() : JY6302.h
  • JY6302_AI_ReadReferenceJunctionData() : JY6302.h
  • JY6302_AI_ReadReferenceJunctionRawData() : JY6302.h
  • JY6302_AI_ReadReferenceJunctionSinglePoint() : JY6302.h
  • JY6302_AI_ReadSinglePoint() : JY6302.h
  • JY6302_AI_SendSoftTrigger() : JY6302.h
  • JY6302_AI_SetAdvanceTriggerType() : JY6302.h
  • JY6302_AI_SetCJDataSource() : JY6302.h
  • JY6302_AI_SetDigitalAdvanceTrigger() : JY6302.h
  • JY6302_AI_SetDigitalReferenceTrigger() : JY6302.h
  • JY6302_AI_SetDigitalStartTrigger() : JY6302.h
  • JY6302_AI_SetExternalSampleClockTerminal() : JY6302.h
  • JY6302_AI_SetPreTriggerSamples() : JY6302.h
  • JY6302_AI_SetReferenceTriggerType() : JY6302.h
  • JY6302_AI_SetReTriggerCount() : JY6302.h
  • JY6302_AI_SetSampleMode() : JY6302.h
  • JY6302_AI_SetSampleRate() : JY6302.h
  • JY6302_AI_SetSamplesToAcquire() : JY6302.h
  • JY6302_AI_SetStartTriggerType() : JY6302.h
  • JY6302_AI_SetUserRJTemperature() : JY6302.h
  • JY6302_AI_Start() : JY6302.h
  • JY6302_AI_Stop() : JY6302.h
  • JY6302_AI_WaitUntilDone() : JY6302.h
  • JY6302_Close() : JY6302.h
  • JY6302_DisconnectSignalRouting() : JY6302.h
  • JY6302_EnableCJ() : JY6302.h
  • JY6302_EnableCJDebouncedData() : JY6302.h
  • JY6302_GetCJDebouncingStatus() : JY6302.h
  • JY6302_GetCJInvalidBounce() : JY6302.h
  • JY6302_GetCJMaxBounce() : JY6302.h
  • JY6302_GetDeviceID() : JY6302.h
  • JY6302_GetDeviceSerialNumber() : JY6302.h
  • JY6302_GetTerminalBlockConnectionStatus() : JY6302.h
  • JY6302_Open() : JY6302.h
  • JY6302_OpenByName() : JY6302.h
  • JY6302_ResetDebouncer() : JY6302.h
  • JY6302_SetCJInvalidBounce() : JY6302.h
  • JY6302_SetCJMaxBounce() : JY6302.h
  • JY6302_SetCJUpdateDataTimeout() : JY6302.h
  • JY6302_SetCJUpdateInterval() : JY6302.h
  • JY6302_SignalRouting() : JY6302.h


6302 C++ Programming Manual: File Members

  • JY6302_DeviceHandle : JY6302.h


6302 C++ Programming Manual: Main Page

6302 C++ Programming Manual Documentation